Texas - Inclement Weather - Rotating Power Outages
Incident Report for Chargify
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 08:24 CST
Monitoring
The Chargify Application itself is not affected and is functioning normally. However, due to inclement weather and critical rotating power outages in Texas, Live Support may be limited at times and longer than normal response times can be expected for support related issues.
Posted Feb 15, 2021 - 12:21 CST