Self Service Page / Card updates displaying warning in some browsers.
Incident Report for Chargify
Resolved
This incident is now resolved: hosted pages are no longer showing the "Deceptive Site Ahead" warning.
Posted 3 months ago. Dec 24, 2018 - 05:51 CST
Monitoring
It appears that Google has revised their status and the self-service pages are no longer marked as unsafe. We are continuing to monitor the situation and will resolve the issue when the official word is received from Google.
Posted 3 months ago. Dec 23, 2018 - 23:49 CST
Update
We will be adding a message to the bottom of all hosted pages in an attempt to clarify the relationship between Chargify and our merchants.

Google guidance suggests:

"On every page that contains first-party branding, explicitly state the relationship between the first and third party, and provide a link for more information. For example, a statement like this:
This service is hosted by Example.com on behalf of Example.charities.com. More information"

In this guidance, the "first-party" is you, the merchant, and the "third-party" is Chargify.

It is unclear if this will assist in removing the "Safe Browsing" block, but we will continue to keep you informed.
Posted 3 months ago. Dec 23, 2018 - 07:11 CST
Update
We continue to try different tactics to get removed from Google's "Safe Browsing" list that is causing this warning to appear. It is difficult because Google gives little information on the actual problem, little recourse, and no contact information.

If you receive one of these warnings, you may be able to help us out by following the link to "report a detection problem" (found by first clicking the "Details" button) and providing Google with the requested information.
Posted 3 months ago. Dec 22, 2018 - 23:48 CST
Identified
We believe that our self service update pages have been mistakenly flagged as phishing attempts by Google. We are working with google now to resolve the problem.
Posted 3 months ago. Dec 22, 2018 - 16:35 CST
Investigating
Users are experiencing the warning "Deceptive Site Ahead" in both Chrome and Firefox browsers when visiting some self service (card update) pages.

We are currently working to resolve the issue.
Posted 3 months ago. Dec 22, 2018 - 11:33 CST
This incident affected: Chargify Hosted Pages.