Square has since resolved the performance issues as of 17:54 PDT.
Posted May 28, 2020 - 21:10 CDT
Monitoring
Square is currently monitoring a performance issue on their end. If you utilize the Chargify+Square solution, you may experience delays in transactions being reflected or other errors. Their latest update is as follows:
***** Monitoring: May 28, 12:06 PDT We’re beginning to see services recover, and we’ll continue to monitor as our Engineers work to ensure the fix will completely resolve the issues.
We want to assure you that throughout this outage, physical card payments have not been affected and have processed as normal, despite a delay in being reflected within transactions.
Thank you for being patient with us, and we’ll return with another update here shortly. *****
We will continue to monitor their status page, and more information is available at https://www.issquareup.com/
Posted May 28, 2020 - 14:45 CDT
This incident affected: Integrations to 3rd Party Services.