Renewal processing behind schedule
Incident Report for Chargify
Resolved
All processing, queues, & jobs are caught up and back to normal. The root cause has been shut down for now and we'll be putting a permanent fix in place over the next few days. Once the permanent fix is finished, we'll also post a complete post-mortem of the issues experienced. At this point, we do not believe there was any loss or corruption of data, so no action is necessary from our merchants.

[Note]: If you requested an export during this period and it has not completed, it may have been removed. Feel free to open a new export for your data or contact support@chargify.com if you need help.

Thanks everyone very much for your patience!
Posted over 2 years ago. Nov 01, 2014 - 15:01 CDT
Monitoring
Subscriptions are back to processing in normal time. Other queues like exports and emails are still a behind by about an hour, but will quickly catch up now.
Posted over 2 years ago. Nov 01, 2014 - 14:38 CDT
Identified
We're continuing to work on ensuring subscriptions get processed on time. We haven't seen that catchup that we'd like and are continuing to work to get it back to 100%. Signups are unaffected, however e-mails, exports, and other ancilliary backend systems may be delayed, as we prioritize renewals as the most important queue to process.
Posted over 2 years ago. Nov 01, 2014 - 13:41 CDT
Monitoring
The queue has returned to normal and all subscriptions are now being processed on their normal schedule. We'll continue to monitor as we clean up and ensure that nothing was missed.
Posted over 2 years ago. Nov 01, 2014 - 12:03 CDT
Update
We continue to work on catching up to get subscription processing back to real-time. We've increased capacity significantly and should be back to normal within the next hour.
Posted over 2 years ago. Nov 01, 2014 - 11:39 CDT
Identified
We have identified an issue where scheduled renewals are taking longer to renew than usual due to high load.
Posted over 2 years ago. Nov 01, 2014 - 10:34 CDT