System-wide outage
Incident Report for Chargify
Resolved
Incident has been resolved and system has returned to normal operation
Posted about 1 year ago. Aug 21, 2016 - 03:19 CDT
Investigating
System-wide outage due to database server failure
Posted about 1 year ago. Aug 21, 2016 - 03:03 CDT